2009年04月13日

続Hpricot

というわけで、Ruby1.8でHpricotを使って……みる前に1.8はgemさんがデフォルトでは入っていないので、先に入れる。

こんな感じ
http://d.hatena.ne.jp/gtaka555/20071012/p3

で、「gem install hpricot」を実行してみたのだがエラーになる。「ファイル名、ディレクトリ名、またはボリューム ラベルの構文が間違っています。」だそうだ。

gem.batを見てみたら、なんかダブルコーテーションの付き方が変な気がする。具体的には「ruby.exe」をくくっているダブルコーテーションの後ろに二重でダブルコーテーションが付いている。なんじゃこりゃと思いながら、とりあえず余分なのを外すとちゃんと動作した。

気を取り直してサンプルソースを書き、実行。

====================
require 'rubygems'
require 'hpricot'
require 'open-uri'
doc = Hpricot(open("http://www.mwsoft.jp/programming/webtools/"))
p (doc/'#title').inner_html
====================

途中、ウィルスセキュリティに通信をカットされて目頭を熱くしつつ、ちゃんと動作を確認。やはり便利だ。

さて、これで何して遊ぼうかと思ったところで本日はタイムアップ。コマンドプロンプトでやっている限りでは、Windowsは不便としか感じないのでFedoraでやろうかなぁと少し思う。


来週からは「日曜は副業しない」というルールを実施するので、もう少しいろいろ出来そう。やりたいことリスト、課題リストに入っているものも片付けられれば良いなぁ。
posted by MW at 00:09| Comment(0) | TrackBack(0) | 書籍紹介 | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:


この記事へのトラックバック
×

この広告は1年以上新しい記事の投稿がないブログに表示されております。